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5. Работа с текстова кутия Text Box.
1. Същност на форматирането.

Една от най-характерните черти на текстообработващите системи е, че съдържанието не зависи от формата, в която е представено. Това на практика дава възможност много бързо едно и също съдържание да приема различна форма.

Промяната на характеристиките на елементи от съдържанието на документа, водеща до промяна във външния му вид, се нарича форматиране.

2.Форматиране на символи

2.1 Характеристики на символите:

Под форматиране на символи се разбира: използване на различни шрифто​ве; размер и цвят на знаци, разстояние между знаци, степени и индекси, подчертавания, удебеляване и др.
Да разгледаме най-често използваните характеристики на символите:

· шрифт – набор от еднотипни знакове, оформени в съответствие с определени естетически и ергономични изисквания;

· големина (кегел) – височината на знаковете; измерва се в пунктове (1 pt =1/72 инча)

· начертание (стил) – различни варианти на изписване на знаковете: нормално, удебелено, курсивно, подчертано и др.)

· цвят и фон;

· набор – малки, главни, малки главни букви и др.
Техниката на форматиране на символи е следната. Създаденият вече текст предварително се маркира, след което се избира съответният формат. Форматирането може да се прави и успоредно с написване на текста. Във втория случай се избира съответният формат и той става валиден от текущата позиция на курсора.

Изборът на формат за знаци се прави от менюто Format >Font. Някои формати са изведени и в инструменталното меню и могат да се избират директно оттам.

2.2 Форматиране чрез менюто Format >Font

Практическа задача 1: Стартирайте Word. Отворете диалоговият прозорец за форматиране на символи чрез менюто Format > Font и го разгледайте. В горната му част се намират три бутона, които отварят съответно три страници на диалоговия прозорец - Font, Character Spacing и Animation. За целта се щрака с левия бутон на мишката върху някой от тях. 

Да разгледаме заедно различните възможности на командата Font:

Страницата Font (шрифт). Съдържа няколко полета:

· Font - от списък се избира желаният шрифт, например: Times New Roman, Verdana, Tahoma и т.н. Не всички шрифтове са кирилизирани. Затова, когато се работи с кирилица, трябва да се избира кирилизиран шрифт.

· Font Style - от списък се избира дали текстът да се изписва нормално, без особености (Regular), почернен (Bold), курсивен (Italic) и т.н. 

· Size - тук се избира размерът на буквите в пунктове. Нормално той е 12. 

· Underline - тук се избира видът на подчертаването: опцията за отсъствие на подчертаване е None, за единично подчертаване - Single, за двойно подчертаване -Double, за вълнообразно - Wave и т.н.

· Color - това е поле за избор на цвят на текста.

· Effects - от това поле се избират различни ефекти върху текста, като: зачертаване (Striketrough), сянка на знаците (Shadow), горен или долен индекс (Supescript или Subscript) и др. 

В полето Preview се наблюдава как изглеждат избраните промени. Ако потребителят ги одобри, потвърждава с ОК, ако не - прави нови промени. За отказ от промените се използва бутонът Cancel.

Страницата Character Spacing. Чрез тази страница се променят разстоянията между знаците.

· Scale (мащабиране по ширина) – променя пропорциите на символите, така че да станат по-тесни или по-широки;
· Spacing (междусимволно разстояние) - полето предлага три възможности за избор: нормални знаци (Normal), разширени знаци (Expanded), кондензирани знаци (Condensed).

· Position - полето се използва за издигане на знаците над нормалното положение в реда (Raised), за разполагане по-надолу от нормалното положение в реда (Lowered), а Normal е за нормализиране на разположението.

Страницата Animation. Използва се за анимиране на знаци. Например, за отсъствие на анимация се избира None, за мигащ фон на текста - Blinking Background и т.н.

2.3. Форматиране чрез икони от лентата с  инструменти

Някои често използвани опции на Font е удобно да се избират от инструменталното меню. Това са свойствата: шрифт, размер на шрифта, удебелен, наклонен (курсив), подчертан, цвят на фона и цвят на символите.
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3. Форматиране на абзаци (параграфи)

3.1 Характеристики на абзаците

Абзацът е текст, който се състои от едно или повече изречения. За отбелязване края на абзац се натиска клавишът Enter. Абзацът притежава характеристики, които са общи за всички символи, които са в него: размер на текстовото поле на абзаца, разстояние между редовете; подравняване на текста, отстъп от началото на реда при започване на нов абзац  и др.

Под форматиране на абзаци се разбира задаване на тези общи свойства.

Да разгледаме най-често използваните характеристики на абзаците:

· подравняване – хоризонталното разположение на знаците на параграфа, указващо дали да се извършва изравняване на началото на редовете (ляво подравняване), края на редовете (дясно подравняване), на началото и края (двустранно подравняване) или на средата на редовете (центриране)

· отстъп – хоризонтално разстояние на блока от знаци на параграфа от лявото или дясното поле на листа. 

· отстъп на първия ред – разстояние на началото на първия ред на параграфа от левия край на параграфа. Ако това разстояние е отрицателно, първия ред виси (стърчи) и се говори за настъп.

· отстояние преди/ след параграфа – вертикално разстояние на блока от знаци на параграфа от предишния/ следващия параграф

· междуредово разстояние – разстоянието между два съседни реда от параграфа.

Техниката на форматиране на параграфи е подобна на техниката на форматиране на символи. Създаденият вече текст предварително се маркира, след което се избира съответният формат. Алтернативно, първо се избира съответният формат и той става валиден от текущата позиция на курсора.

Форматирането на абзаци може да се извърши чрез менюто, чрез бутони от инструменталната лента, а някои от свойствата могат да се зададат и чрез специални плъзгачи върху хоризонталната линия.

3.2 Форматиране чрез менюто Format > Paragraph
Практическа задача 2: Стартирайте Word. Отворете диалоговият прозорец за форматиране на абзаци чрез менюто Format > Paragraph и го разгледайте. В горната му част се намират два бутона, които отварят съответно две страници на диалоговия прозорец – Indents and Spacing (Отстъпи и разстояния) и  Line and Page Breaks (Прекъсване на редове и страници). За целта се щрака с левия бутон на мишката върху някой от тях. 

Да разгледаме заедно основните възможности за форматиране на параграфи на страницата Indents and Spacing:

· Alignment (подравняване) - това е списък, от който се избира начин на подравнява​не: отляво - Left, отдясно - Right, двустранно - Justified, центрирано - Centered. 
· Indentation (отстъпи) - използва се за промяна на границите на текстовото
поле съответно отляво (Left) и отдясно (Right). Ако от полето Special се избере First line, то в прозорчето By може да се зададе отстъп на първия ред.
· Spacing before/after (отстояние преди/след параграфа)
· Line Spacing (разстояние между редовете). Най-малкото разстояние е Single. Стандартното междуредие е 1.5.
Направените промени се наблюдават в прозореца Preview.
Не бива да се подценява и страницата Line and page breaks (Прекъсвания на ред и страница):

Orphan -сираче (първи ред); Widow-  вдовица (последен ред) – забранява оставането сам на страница на първия или последния ред от абзаца;
Keep lines together - Забранява прекъсване на страницата в рамките на абзаца;
Keep with next - Забранява прекъсване на страницата между абзаца и следващия абзац;
Page break before – Принудително прекъсване на страницата преди абзаца
3.3 Форматиране чрез икони от лентата с  инструменти

Най-често за форматиране на параграфи се използват инструментите за подравняване
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3.4 Форматиране чрез хоризонталната линия

Промените за лява и дясна граница (поле), както и ляв и десен отстъп и отстъп на първия ред , могат да бъдат извършвани с помощта на линията над текстовото поле.
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3.5 Форматиране на текст чрез клавишни комбинации

За задаване на междуредово разстояние може да се ползват клавишните комбинации: Ctrl+1 (единично);Ctrl+2 (двойно); Ctrl+5 (1.5 междуредово разстояние).

За задаване на подравняване се ползват комбинациите: Ctrl+L-ляво (Left);  Ctrl+R – дясно (Right), Ctrl +E – центрирано (cEnter), Ctrl+J – двустранно подравнено (Justify).
Често се използват и клавишни комбинации за промяна на стила на символите: удебеляване - Ctrl+B (от Bold), наклоняване (курсив) - Ctrl+I (от Italic); подчертаване - Ctrl+U (от Underline).
4. Копиране на форматирането 
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За бързо форматиране, като се ползва форматирането на образец, може да се ползва инструментът “четка”       :

1. Избира се текстът-образец.

2. Щрака се върху инструмента “четка”       (двукратното щракане дава възможност за пренасяне на форматирането върху повече от един обект)

3. Маркира се с мишката текстът-цел (щраква се в текста, ако се пренася само форматиране на абзац).

5. Работа с текстова кутия Text Box
Текстовата кутия дава възможност за разполагане на части от текста на произволно място в страницата. Такава необходимост възниква при създаване на нетрадиционни документи като рекламни брошури, обяви и др. под.

Вмъкването на текстова кутия се извършва от менюто Insert>TextBox. В появилата се рамка Drawing Canvas се щраква с мишката и се влачи по диагонал, за да се очертае правоъгълника на текстовата кутия. След това в нея може да се пише. Кутията може да се влачи с мишката до желаното място. Може да се форматира чрез настройки в диалоговия прозорец Format Text Box, който се извиква с едноименната команда от контекстното меню (дясно щракване на мишката върху кутията). Задават се цвят и прозрачност на запълване; цвят, дебелина и стил на линията на рамката, размери на кутията, разположение спрямо основния текст и др.
Забележка: Създаването на рамката Drawing Canvas обикновено пречи на оформянето на документа. За премахването й, текстовата кутия се влачи извън рамката, след което рамката се щраква с мишката и се изтрива с клавиша Delete.
Практическа задача 3: Отворете файла Printeri.doc и го запишете като Printeri-име на ученика.doc
а) Форматиране на символи 
1. Форматирайте символите на заглавието да бъдат с шрифт  Arial Black, размер 14, ефект - All Caps
2. Форматирайте символите на останалата част от текста да бъдат с шрифт Arial, размер 12
3. Форматирайте символите на всяка от точките (подзаглавията) да бъдат с удебелен, наклонен и подчертан шрифт.

4. Маркирайте различни части от текста и експериментирайте с различните свойства на символите, които се задават от прозореца Format Font и от изучените бутони на инструменталната лента

б) Форматиране на абзаци
5. Форматирайте заглавието да бъде центрирано.

6. Форматирайте всяка от точките (подзаглавията) да бъде ляво подравнена

7. Форматирайте текста след всяка точка да бъде двустранно подравнен, с отстъп на първия ред 1 см.

8. Форматирайте текста след точката "Матрични принтери" да бъде с ляв отстъп 2 см и   десен отстъп 1 см.
9. Маркирайте различни части от текста и експериментирайте с различните свойства на абзаците, които се задават от прозореца Format Paragraph, от изучените бутони на инструменталната лента и от хоризонталната линийка.
Преглед на видовете принтери

1. Матрични принтери

Матричните принтери се използват предимно за отпечатване на формуляри, които често са на два или три пласта. Те все още се предлагат, въпреки че вече не са толкова популярни. Тези принтери са евти​ни и предлагат изход с текстово качество под формата на точки. Печатащата глава се състои от 7 до 9 игли, които създават изображение върху лист хартия с помощта на мастилена лента. Те са подходящи за текст, но не и за графики в повечето случаи. 

2. Мастиленоструйни принтери

Цветните мастиленоструйни принтери дават добро качество за цветни и черно-бели копия. Изображението се създава чрез впръскване на струйки мастило върху страницата. Обикновеното мастило е водоразтворимо, т.е. отпечатаните копия са неустойчиви. Цените на тези принтери са сравнително ниски  (от 80 до почти 1000 долара), но консумативите им са скъпи. Съществува възможност за отпечатване върху прозрачно фолио, което се различава от това за лазерните принтери.

Най-популярните мастиленоструйни принтери на пазара днес са моделите на Epson от серията Stylus, на Hewlett-Packard и Canon. Като цяло, тези принтери могат да дават печат до 1440 dpi. При тази разделителна способност човешкото око не може дори да различи отделните точ​ки, които изграждат изображението. 

Фотографските принтери често използват шест цвята вместо четири, въпреки че тази тенденция се променя, тъй като сега дюзите са рафинирани до такава степен, че произвеждат капчици с размер четири пиколитра (1 пиколитър се равнява на 10-12 от литъра). За максимално качество трябва да се купи хартия с фотограф​ско качество, предназначена специално за мастиленоструйни принтери, за предпочитане за съответните марка и модел принтер. За архивни цели (копия, които не избеляват при излагане на слънче​ва светлина или ултравиолетови лъчи от халогенни лампи) се използват принтери, които могат да работят с новите архивни мастила. Някои от моделите на Epson са подходящи за целта. 

3. Лазерни принтери

Когато е необходимо високоскоростно и висококачествено отпе​чатване, един лазерен принтер е добър избор. Лазерните принте​ри се използват предимно за черно-бели документи. Достъпни са също така цветни лазерни принтери, но на доста висока цена. Цените на лазерните принтери са неколкократно по-високи от тези на мастиленоструйните принтери, но са много по-бързи от тях и консумативът на единица копие е значително по-евтин.

Лазерните принтери работят чрез зареждане на хартията с по​ложителни йони на местата, където би трябвало да се появят бук​ви или изображение. Тонерът е зареден отрицателно и следова​телно се привлича от хартията на съответното място. Едно устройство за разтапяне изпича тонера върху хартията.

4. Сублимационни принтери

Сублимационните (dye-sublimation) принтери, познати също като thermal-wax принтери, завъртат покрита с восък лента между печатащата глава и хартията. Прилага се определено количество топлина за прилепване на восъка към хартията. Цената на самата хартия е доста висока, но качеството е очевидно. Копията от такъв принтер изглеждат доста впечатляващо, с едно изключе​ние - ако погледнете под ъгъл, можете да видите т.нар. banding, представляващо фина линия между всяко преминаване на печатащата глава по хартията. Мастилено-струйните принтери не по​казват такава аномалия, тъй като в резултат от преминаването на печатащата глава се получава непрекъснато изображение.

5. Термопринтери

Те работят на почти същия принцип като сублимационните принтери, с тази разлика, че използват боя, вместо восък. Работят с лъскава фотографска хартия. Тази специална хартия е покрита с полиестер и може да бъде доста скъпа. Качеството на термопринтерите е сравнимо с това на сублимационните принтери.

6. Многофункционални машини.

През последните няколко години се появиха машини, съчетаващи функциите на скенер, принтер, копирна машина и факс. Те са  сравнително евтини и подходящи за малки офиси, в които няма място за няколко отделни устройства.

Задача за домашно.

Изпълнете самостоятелно Практическа задача 3 и представете форматирания файл на дискета или флаш памет.
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