Професионална гимназия по механотехника и електротехника „М. В. Ломоносов” гр. Добрич

Въвеждане и редактиране на текст
1. Елементи на компютърния текст – знак, дума, изречение, ред, абзац, страница, раздел

2. Въвеждане на текст с Word – предназначение  на клавишите Shift, Caps Lock, Enter, интервал
3. Изтриване 

а) знак – Backspace (отляво), Del (отдясно)

б) дума –  Ctrl + Backspace, Ctrl + Del

4. Вмъкване – Ins превключва между заместване и вмъкване

5. Сливане и разделяне на параграфи

6. Отменяне на действия – Undo и отказване от отменянето – Redo
7. Придвижване из документа – основни клавишни комбинации Home, End, Ctrl+Home, Ctrl+End, PgUp, PgDn, стрелки

8. Маркиране на основните структурни единици: дума, ред, изречение, абзац, цял документ

9. Преместване и копиране на текст:

а) чрез Clipboard – Cut, Copy, Paste

б) чрез ляво и дясно влачене

10. Търсене (Find) и заместване (Replace)
1. Елементи на компютърния текст 

Всеки текст се състои от символи, които от своя страна изграждат други структури на текста. Да си припомним някои от тях и да разгледаме някои нови структури на текстовия документ, които ще използваме в следващите уроци.
Знак ( символ) - въвежда се с натискането на клавиш или комбинация от клавиши и представлява най-малката единица от данни в документа.
Дума - група от символи, отделени от останалите знаци с интервал от две​те страни, с табулация или с препинателен знак.
Внимание! Препинателните знаци (точка (.), запетая (,) и д р. се изписват слято с предхождащата ги дума и след тях задължително се оставя интервал.
Ред - поредица от символи или думи, разположени на един ред.
Внимание! Преминаването от един ред на друг става автоматично при въ​веждане на текст в компютъра, т.е. въвеждащият текста не натиска клавиш (или валяка, както е при пишещите машини).
Изречение - последователност от думи, предшествана от знак за интервал, знак за нов ред или край на параграф и последвана от препинателен знак.
Параграф (абзац) - последователност от знаци или изречения, последвани от знака за край на параграф. Той се въвежда от клавиатурата чрез натис​кане на клавиша ENTER.
Колона от параграфи - разположени един под друг параграфи.
Страница - частта от текста, която може да се отпечата от едната страна на лист хартия.
Раздел - обхваща една или няколко страници от документа, които са офор​мени по един и същ начин и представляват логически завършена част.
2. Въвеждане на текст.

При набиране на текста е желателно да се ползва десетопръстната система. Желателно е с цел повишаване на производителността, редактирането на текста да се прави след приключване на набирането. Същото се отнася и за форматирането.

Най-често при набиране и редактиране се извършват следните действия:

1. Смяна на кирилица и латиница

І начин – Щраква се върху индикатора за езика  [image: image1.jpg]~ |Bul




 и избираме език   

ІІ начин – Чрез клавишна комбинация - най-често ляв Ctrl или ляв Alt+Shift

Забележка: Ползват се два вида клавиатурни подредби за кирилица – БДС и фонетична.

2. Въвеждане на главни букви (смяна на регистъра)

Shift (ляв или десен) - действа докато е натиснат заедно със символа (като бутона на звънец)

Caps Lock- Последователното му натискане превключва между главни и малки букви (като ключ за осветление). За разлика от Shift не действа върху цифрите и специалните символи.

3. Промяна на регистъра на въведен текст

Често се налага даден текст да бъде променен така че всичките му букви да станат само главни или само малки или само първата буква да бъде главна  и т.н. За да не се набира наново текста, предвидени са команди за превръщането на буквите от малки в главни и обратно: 

1. Маркира се текстът или се позиционира маркерът в думата.

2. Изпълнява се Format / Change Case или Shift + F3

За въвеждане на празно място между думите се натиска клавиша Интервал. 
За създаване на нов абзац (параграф) се използва клавиша Enter. Натискането на Enter без да е въведен текст води до създаване на празни абзаци. Това е бърз и груб начин за раздалечаване на части от текста. За преминаване на нов ред не е необходимо да се натиска Enter, тъй като програмата автоматично пренася на нов ред текста, който не се събира на текущия ред. Автоматично става и пренасянето на нова страница, когато се изчерпи мястото на текущата страница.
Ако трябва да се прекъсне ред в рамките на един абзац, използва се клавишна комбинация Shift+Enter (ръчно прекъсване на ред). Ако трябва да се прекъсне страница и да започне принудително писане на нова, използва се клавишна комбинация Ctrl+Enter или Insert>Break>Page Break.
3. Изтриване на текст.
Има различни начини за изтриване на части от текста. Ще ги разгледа​ме по-долу.
· Del - изтрива един знак след курсора.
· Backspace (() - изтрива един знак пред курсора (вляво от курсора).
Задържането на горните два клавиша повтаря многократно тяхното дейс​твие и изтрива последователно знаци, докато натискането на клавишите продължава.
При използване на клавишите Backspace или Del изтритият текст не се пази в буфер и не може да се копира след това. Такива възможности има командата Cut.
· Командата Edit —> Cut (респ. съответстващият й бутон "ножица", или клавишна комбинация Ctrl + Х)   - изтрива маркиран текст и го запазва в бу​фер, наречен Clipboard, откъдето може да бъде копиран.
· дума се изтрива с клавишните комбинации –  Ctrl + Backspace (вляво от курсора), Ctrl + Del (вдясно от курсора)
4. Вмъкване на текст.

Тъй като текст се вмъква от мястото на курсора, достатъчно е чрез някой от познатите начини да придвижим курсора на желаното място и въвеждане​то на текста от клавиатурата може да започне.
При вмъкване на текст има два режима:

· вмъкване на символи (Insert);

· замяна на символи (OVR);

Превключването между двата режима се извършва с клавиша Insert или чрез двойно щракване върху надписа OVR в лентата на състоянието.
5. Сливане и разделяне на параграфи.
Сливане на два параграфа.

Изтрива се знакът за край на параграф ¶ по един от начините:

· чрез позициониране на маркера в края на първия параграф и натискане на клавиша Delete

· чрез позициониране на маркера в началото на втория параграф и натискане на клавиша Backspace (
Разделяне на параграф на два параграфа.

Позиционира се маркерът в точката на разделяне и се натиска клавиш ENTER

6. Отменяне на действия (възстановяване на предишно състояние на текста).
Последната извършена промяна може да се възстанови чрез командата Edit > Undo (респ. нейните горещи клавиши Ctrl+Z или бутона 
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). Отказване от възстановяването се извършва с Edit > Redo
7. Движение в документ.
Коригирането на грешките в текст много често изисква движение в различни части на документа. За целта могат да се използват мишка, клавиши и кла​вишни комбинации.
За демонстрация се използва документ с поне 2 страници.

· Мишка - курсорът може да се придвижи върху произволна видима на екрана част от текста, като се щракне на желаното място с левия бутон на миш​ката. Това е един от най-често използваните начини за движение по текста.
· Клавиши-стрелки ((((()- чрез тях курсорът се движи по текста в съответната посока, без да го променя и със стъпка, съответства​ща на един ред (нагоре или надолу) или един знак (напред или назад).
· PgUp - придвижва курсора един екран нагоре.
· PgDn - придвижва курсора един екран надолу.
· Home - придвижва курсора в началото на реда.
· End- придвижва курсора в края на реда.
· Ctrl + Home - придвижва курсора в началото на документа.
· Ctrl + End- придвижва курсора в края на документа.
· Ctrl + ( - придвижва курсора една дума надясно.
· Ctrl +( - придвижва курсора една дума наляво.
· Ctrl +  (- придвижва курсора един абзац нагоре.
· Ctrl +  (- придвижва курсора един абзац надолу.
От дясната страна на клавиатурата се намира тъй нареченият цифров блок. Той също съдържа клавишите за движение, както и цифрите от 1 до 9. При включен клавиш NumLock този блок работи като цифров, а при изключен – като клавиши за движение.
8.Маркиране на текст.
С маркиран текст могат да се извършват различни операции - изтрива​не, копиране, преместване, форматиране, разпечатване и др. Затова е важ​но да познаваме техниките за маркиране на различни части от текста.
· Маркиране на дума - постига се чрез двойно щракане с левия бутон на мишката върху думата.
· Маркиране на изречение - щрака се с левия бутон на мишката върху из​речението при натиснат клавиш Ctrl.
· Маркиране на ред -  щрака се с левия бутон на мишката в полето пред реда.
· Маркиране на абзац - щрака   се двойно с левия бутон на мишката в полето пред абзаца.
· Маркиране на произволен текст - курсорът се позиционира в начало​то на текста, който ще се маркира, и се влачи до края на текста.
· Маркиране на цял документ - осъществява се чрез командата Edit > Se​lect All. Друг начин е клавишната комбинация Ctrl  +5 от цифровия блок или Ctrl  +A.
За отмяна на маркировката се щрака върху произволна част от полето. Припомнете си, че по същия начин се отказваме и от маркирана команда в Windows.
9. Преместване и копиране на текст.

9.1 Преместване

Чрез системния буфер (Clipboard)
1) Маркираме текста, който ще местим, по някой от познатите ни начини.
2) Активираме командата Edit > Cut (съответният й  бутон от инстру​менталното меню или горещите клавиши Ctrl + Х). Маркираният текст се изтрива и се запомня в Clipboard.
3) Позиционираме курсора на мястото, където желаем да преместим текста.

4) Активираме командата Edit >Paste (или горещите й клавиши Ctrl +V). Тя вмъква текста от Clipboard на посоченото място.

Чрез влачене с мишката

1) Маркираме текста, който ще местим.
2) Влачим маркирания текст, докато курсорът се позиционира на място​то, където ще го местим, и отпускаме бутона на мишката.
Този начин е бърз и удобен, поради което е и широко предпочитан.
9.2. Копиране на текст.
Чрез системния буфер (Clipboard)
1) Маркираме текста, който ще копираме.
2) Активираме командата Edit > Copy (съответния й бутон от инстру​менталното меню или горещите клавиши Ctrl + С). Маркираният текст остава на място, но се запомня в Clipboard.
3) Позиционираме курсора на мястото, където желаем да копираме мар​кирания текст.
4) Активираме командата Edit >Paste (или горещите й клавиши Ctrl +V).Тя вмъква текста от Clipboard на посоченото място. 
Чрез Ctrl + влачене с мишката
1) Маркираме текста, който ще местим.
2) Влачим маркирания текст, докато курсорът се позиционира на място​то, където ще го местим, и отпускаме бутона на мишката.
10. Търсене и заместване на даден текст с друг текст.

Как бихте постъпили, ако в напечатан текст, например списание или книга, трябва да откриете всички срещания на някаква дума или фраза? Вероятно ще прочетете текста и ще отбележите по някакъв начин търсеният текст. Това може да отнеме много време и труд и не сме застраховани, че няма да пропуснем нещо или да направим грешка. В компютърните текстове всичко това се прави много лесно и бързо и сега вие ще се научите как да го вършите.

10.1 Търсене

За търсене на текст се изпълняват следните действия:

1) Активираме командата Edit>Find. Отваря се диалогов прозорец
2) В полето Find what се изписва текстът, който ще се търси. Търсенето започва след натискането на клавиша Find Next от позицията на курсора. На екрана се визуализира онази част от текста, която съдържа зададения за търсене текст. Самият текст се отделя чрез маркировка. При всяко следващо натискане на бутона Find Next се визуализира следващото място, което съдържа зададения текст. Търсенето продължава, докато активираме бутона Find Next. Когато се претърси целият документ, се появява съобщение за това („Word has finished searching the documents") и се очаква натискане на бутона ОК, след което се чака ново търсене. Отказът от търсене в произволен момент става с бутона Cancel или с бутона Close.
10.2 Заместване

Намереният текст може да бъде заместен с друг текст. 
1) Активираме командата Edit> Replace. Отваря се същият диалогов прозорец, но на страницата Replace (заместване)
2) В полето Find what се изписва текстът, който ще се търси.
3) В полето Replace with се изписва изразът, с който се замества намереният израз
4) Бутоните Replace и Replace All са съответно за еднократно заместване и заместване в целия текст. 
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