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1.  Проектиране на принципна електронна схема

1.1. Предназначение и кратко описание
Нискочестотният генератор-пробник е предназначен да създава електрически колебания с ниска честота. Използва се за настройка и измервания на различни електронни устройства.
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Стойностите на елементите във веригата на обратната връзка (кондензаторите С1-С4 и резисторите R1 и R2 определят честотата на генерираното изходно напрежение. В конкретния случай със стойностите, дадени в схемата, на изхода на генератора се получава напрежение с честота в границите от 1400 до 1700 Hz (регулира се с тример-потенциометъра R2). Чрез потенциометъра R6 може да се регулира амплитудата на изходното напрежение.                                                                                                                                                                            
Транзисторите могат да бъдат от типа SFT 353 или други нискочестотни транзистори, чийто коефициент на усилване по ток 40-50, а резисторите е желателно да бъдат малогабаритни, от типа МЛТ-0,125.
Настройката на пробника се свежда до оптимален избор на съпротивлението R5 (в интервала 2.2- 3.9 kΩ), чрез което се изменя дълбочината на обратната връзка, докато се удовлетвори условието за самовъзбуждане).

1.2. Спецификация на елементите на схемата.

	№
	Означение в схемата
	Наименование на елемента
	Тип/стойност
	Брой елементи

	1. 
	Т1, Т2
	транзистор
	МП 114
	2

	2. 
	R1
	резистор
	150 К
	1

	3. 
	R2
	тример-потенциометър
	4.7 К
	1

	4. 
	R3
	резистор
	9.2 K
	1

	5. 
	R4
	резистор
	750
	1

	6. 
	R5
	резистор
	2.7 K
	1

	7. 
	R6
	потенциометър
	10 K
	1

	8. 
	C1, C2
	кондензатор
	220 pF
	2

	9. 
	C3, C4
	кондензатор
	4,7 nF
	2

	10. 
	C5
	кондензатор електролитен
	22 μF
	1


1.3. Създаване на проект
За проектиране на чертожната документация на електронното изделие ще бъде използвана програмната система Protel DXP 2004 на фирмата Altium.

За създаване на нов проект се използва командата File > New > PCB project, при което се създава документ със служебното име PCB_Project1.PrjPCB. Проектът се съхранява с желано от проектанта име чрез командата File > Save Project As, като се поставя в подходяща папка чрез използване на иконите в горната част на прозореца Save As  [image: image2.png]Savein
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. В случая проектът е съхранен под име N_gen. PrjPCB в папката NCH generator.
1.4. Създаване на принципна схема 

За създаване на нова схема  се избира командата от менюто File > New > Schematic, при което в листа на проекта се появява празен лист на принципна схема с име по подразбиране Sheet1.SchDoc, който автоматично се добавя към проекта (фиг. 1.1).
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фиг. 1.1 Създаване на нова схема  

Чрез командата File > Save As се дава подходящо име на схемата, в случая N_gen.schdoc.
1.5. Настройване на параметрите на листа на схемата

1. Отваряне диалоговия прозорец Document Option
От менюто се избира командата Design > Document Options, която отваря диалоговия прозорец Document Options. За разлика от редактора на печатни платки, където всички графични примитиви трябва да имат истински геометрични размери, оформянето на схемите се извършва в дискрети – някакви условни единици за измерване. За да се постигне отпечатаната схема да има правилни размери в милиметри, трябва да се подбере мащаба на отпечатване.
Редакторът на  принципни схеми на Protel има дискретност 0.01 инча, което е около 0.25 мм. Тъй като за оформяна на схемите, съгласно ЕСКД е достатъчна точност 0.5 мм, избира се мащаб 1 мм= 2 дискрета, което дава възможност да се използват без проблем микросхемите от фирмените библиотеки. 

2. Настройване на стъпката на мрежата

Настройва се стойността на видимата мрежа Visible Grid, облекчаваща ориентирането по схемата, на 10, което съответства на 5 мм.
3. Настройва се стъпката на прилепване Snap Grid, определяща дискретността на преместване на курсора по схемата, на 2, което съответства на 1 мм.

4. Задават се размерите на листа. Тъй като схемата е малка, достатъчно е да се ползва формат А4, който е с размери 210Х297 мм. За да има полета по 10 мм от всички страни, размерите на листа трябва да бъдат 230Х317. Ползвайки въведеното по-горе правило 1 мм= 2 дискрета, настройват се потребителски размери на листа, за което се включва кутията Use Custom Style. В полето Custom Width се въвежда 460 (2х230), а в полето Custom Height се въвежда 634 (2Х317).

5. Настройва се броя на координатните зони, необходими за автоматично преномериране на позиционните обозначения по хоризонтала (X Region Count) равно на 6, а по вертикала (Y Region Count) равно на 8. В този случай зоните ще имат размер около 40 мм, което е напълно достатъчно. 
6. Настройва се широчината на полето Margin Width на 20 единици (10 мм).

Чрез бутона ОК се съхраняват всички установени параметри (фиг 1.2).
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фиг. 1.2 Настройка на параметрите на листа на схемата

7. Изпълнява се команда View > Fit Document (клавишна комбинация V, D), което автоматично нагажда мащаба на изобразяване на листа към екрана.
Направените настройки се отнасят само до този схемен лист.

1.6. Настройване на редактора на  принципни схеми

1. Изпълнява се командата Tools > Schematic Preferences (клавишна комбинация T, P), при което се отваря диалоговият прозорец Preferences, чиито настройки се отнасят към всички листи със схеми.
2. Преминава се към преградката Default Primitives и се включва кутията Permanent (постоянно), след което се затваря прозореца с бутона ОК.

3. Съхранява се настроения лист на схемата с помощта на командата File > Save (горещи клавиши F, S).

За бързо задаване на параметрите на листите на схемите може да се използват отнапред създадени шаблони или съществуващи схемни листи. Те представляват заготовка на листа на  принципната схема с установени параметри, съхранена във файл с разширение .DOT. Смяната на шаблона се извършва с командата Design> Template> Set Template File Name, а актуализиране на чертежа в съответствие с промяната на шаблона – чрез  Design> Template> Update. Готови листи с шаблони по ГОСТ (които са същите като по БДС, но някои надписи се различават, тъй като са на руски) могат да се изтеглят от http://www.eltm.ru/store/Protel_Titles_For_SCH.zip. Те са за Protel 99,  но лесно се конвертират в по-нови версии. Ако се налага промяна, тя се извършва в шаблона, чрез инструментите за чертане на неелектрични обекти (линии и текстови кутии). В прозореца Document Options, преградка Parameters, може да се създават параметрични променливи и да се задават техни стойности (фиг 1.3). Имената на параметрите могат да се въвеждат в текстови кутии, като се предшестват от знака за равенство. При отпечатване се показват стойностите на параметрите, а не техните имена.
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фиг. 1.3 Настройка на параметричните променливи
1.7. Чертане на схемата
1. Търсене на компонентите в библиотеки и включване на библиотеки
Отваря се панела Libraries чрез командата от менюто Design > Browse Library. Щраква се радиобутона Components (ако не е избран).  Щраква се бутона Search и в появилия се диалогов прозорец Search  Libraries се задават параметри за търсене. В полето Path (път) се задава пътят до папката, в която се намират библиотеките, в случая C:\Program Files\Altium2004\Library. На кутията Include Subdirectories (търсене в подпапките) се поставя отметка.
Търсенето на резистори се извършва чрез написване в полето Name на *res* (звездичките заместват символите в началото и края на думата). За започване на търсенето се щраква бутона Search. Част от получените резултати са показани на фиг. 1.4а. Вижда се, че подходящия елемент се намира в библиотеката Miscellaneous Device.IntLib. Тя вече е инсталирана, и затова бутонът Install е недостъпен. 

За настоящата схема са най-подходящи резисторите Res1, тъй като са маломощни. Библиотечното описание на резистора се състои от символ за редактора на  принципни  схеми, компонентен отпечатък за редактора на платки, Spice модел за моделиране и модел за анализ цялостността на сигналите (фиг. 1.4 б). Избира се Res1 и се щраква бутона Select, при което се влиза в библиотеката, съдържаща Res1, като Res1 е избран. Ако се щракне двукратно Res1,  се влиза в режим на поставяне на елементи, при който всяко щракване с мишката в работния лист поставя екземпляр на избрания елемент, в случая Res1.
В същата библиотека се намира и библиотечно описание на потенциометър RPot, необходим за потенциометъра R6 и RPot SM, необходим за тример-потенциометъра R2. Тример-потенциометърът може да бъде открит чрез търсене по ключовата дума *trim*, написана в полето Description (описание), срещу което трябва да има отметка.
Търсенето на кондензатори се осъществява чрез ключовата дума *cap* (от "capacitor") в полето Name, а на електролитни кондензатори – чрез комбинация на *cap* в полето Name и *polar* в полето Description. Намират се в същата библиотека.
При търсене на транзистори, в библиотеките не може да бъде открит нито един от посочените транзистори или негов заместител (SFT353, МП114, 2Т6822), затова се възползваме от възможността за заместване – какъв да е нискочестотен транзистор, с коефициент на усилване по ток 40-50. Ще бъде използвано библиотечно описание на транзистор 2N3906.
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	а) Резултати от търсене на резистори с ключовата дума *res*  
	б) библиотечно описание на Res1

	фиг. 1.4 Търсене на резистори с ключовата дума *res*


2. Добавяне на елементите към схемата

В библиотеката Miscellaneous Device.IntLib се открива резисторът Res1 и чрез двойно щракване върху името му или чрез бутона Place в горната част на прозореца редакторът се включва в режим на поставяне на елементи. Натиска се клавишът Tab, за да се влезе в режим на редактиране свойствата на резистора и се настройва обозначението (Designator) да бъде R1,  да няма отметка в кутията Visible (видим)  на коментара Comment), стойността (Value) да бъде 150К, а графичният режим (Mode) да бъде Alternate (означение на резистора като правоъгълник, както е по БДС). След това, за да се постави резисторът, се щраква на подходящо място в чертожното поле. По подобен  начин се добавят останалите резистори, но тъй като редакторът е вече в режим на поставяне на елементи, не е необходимо използването на бутона Place или двойно щракване върху името Res1. За завъртане на елемента на 90 градуса по време на поставянето в чертежа се използва клавишът интервал. За излизане от режима на поставяне на елементи се натиска клавишът Esc.
За добавяне на кондензаторите се избира елемента Cap. За да се достигне по-бързо до желания елемент, може да се използва филтър, като в текстовата кутия се написва началната част от името му, последвана от глобалния символ "звездичка", заместващ останалата част от думата (фиг. 1.5).
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фиг. 1.5 Филтриране на показваното съдържание на библиотеката
Поставянето на кондензаторите се извършва аналогично на резисторите, като при това се задават съответните стойности: 4.7n (или 4n7) и 220pF (за десетична точка се използва точка; между стойността и размерността няма интервал; размерността е с латински букви).
За електролитния кондензатор C5 се избира радиален кондензатор, тип Cap Pol1. Стойността му е в микрофаради, което се задава чрез буквата u (22u).
В библиотеката Miscellaneous Device.IntLib се избира транзисторът 2N3906. Като означение (designator) се задава Т1. За коментара се оставя включена отметката Visible, което води до показване в чертежа на типа на транзистора 2N3906. По време на поставяне на транзистора, се натиска клавиша Y, което води до огледално обръщане, в съответствие с необходимото разположение.
Разположените в чертежа елементи без връзки са показани на фиг. 1.6.
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фиг. 1.6 Заготовка на схемата без връзки

На този етап в принципната схема се използват символи на елементите от стандартните библиотеки. Тъй като символите от тези библиотеки се различават от приетите в България условни графични изображения, те ще бъдат редактирани.

3. Редактиране на елементите
С командата от менюто Design >Make Project Library се създава библиотека с елементите на проекта. В панела Projects под названието на проекта се добавя нова категория документи под името Schematic Library Documents, в което присъства документ с разширение schlib – библиотеката на проекта. Върху името на новия файл се щраква двукратно, при което се отваря редакторът на библиотеки на елементи на принципни схеми, а в долната част се появява нов панел Library Editor.
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фиг. 1.7

Тук присъстват само 6 елемента, което съответства на броя на използваните типове елементи. Символите на елементите ще бъдат променени така, че да съответстват на изискванията на БДС.
Редактиране на символа на транзистора:

1. Избира се в редактора елемента 2N3906, при което символът му се изобразява на екрана.

2. Настройва се видимата мрежа на 5 мм (10 дискрета). Чрез Tools >Document Options се отваря диалоговия прозорец Library Editor Workspace и в полето Visible Grid се записва 10.
3. В същия прозорец се настройва минималната стъпка на прилепване Snap Grid на 1 дискрет, което съответства на 0.5 мм. По-нататък измененията на стъпката може да се извършват чрез командата View>Grids>Set Snap Grid. Всички въведени стойности се запомнят, а бързото превключване между тях се извършва с горещия клавиш G.
4. Максимално се приближава съществуващия чертеж чрез CTRL+PageDown.
5. С помощта на командата Place>Ellipse се стартира чертане на окръжността.

6. Натиска се клавишът Tab  и в отворения прозорец се настройват параметрите на окръжността. Изключва се опцията Draw Solid (запълване). Задава се дебелина на линията Small, което в избрания мащаб съответства на 0.5 мм. Хоризонталният и вертикалният радиус са 12 дискрета (6 мм). Натиска се ОК (фиг 1.8). Центърът на окръжността се разполага в началото на координатната система (0,0). 
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фиг 1.8. Чертаене на окръжността на транзистора
7. Начертават се правите линии на емитера и колектора чрез Place>Line и стрелката чрез Place>Poligon. За симетрията се следи чрез координатите на началната и крайната точка.
8. Пренасят се изводите от стария символ чрез преместване. Излишните линии от стария символ се изтриват.
9. Щраква се двукратно върху извода на колектора и в диалоговия прозорец Pin Properties се задава дължина (Length) на извода 0, което го изражда в точка. Целта е да се скъсят изводите, за да се направи схемата по-компактна. По същия начин се скъсява и изводът на емитера. За извода на базата се задава дължина 10 (фиг.1.9 а).
10. Промените се съхраняват чрез File>Save, като при първото съхраняване се задава име и папка на библиотеката.
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	б) тример-потенциометър


фиг. 1.9 Редактирани символи на елементи
Редактиране на символа на тример-потенциометъра:

1. В панела Projects се щраква двукратно библиотеката N_gen.schlib, което я отваря в режим на редактиране. 
2. Като заготовка ще бъде използван потенциометъра RPot. Щраква се с десния бутон върху името му и се копира чрез Copy и Paste от контекстното меню, при което в библиотеката се появява негово копие с име RPot_1. 
3. RPot_1 се щраква двукратно, при което се отваря прозорецът със свойствата му.
4. Променят се Library Ref (името, с което се появява в библиотеката) на Trimmer  и Description (описание) на Trimmer-Potentiometer. Коментарът (Comment) също се променя на Trimmer.  
5. Изтриват се всички линии на потенциометъра, с изключение на изводите.
6. Чрез командата Place>Rectangle
се стартира начертаване на правоъгълник. 

7. Натиска се клавишът Tab  и в отворения прозорец се настройват параметрите на правоъгълника. Изключва се опцията Draw Solid (запълване). Задава се дебелина на линията Small, което в избрания мащаб съответства на 0.5 мм.

8. Чрез щракване и влачене в чертожното поле се очертава правоъгълника. Премества се на подходящото място.
9. Начертава се наклонената линия и късата чертичка чрез командата Place>Line, като се извършва и настройка на свойствата на линията чрез клавиша Tab. За превключване между режимите на чертане (ортогонални линии, 45 градуса, произволен ъгъл) се използва клавишът интервал.

10. Изводите се преместват, така че да се долепят на подходящите места. При необходимост се завъртат по време на местенето чрез клавиша интервал (фиг. 1.9 б). 
11. Промените се съхраняват чрез File>Save.
Обновява се изходната схема с новите символи, като в режима на редактиране на библиотеки се изпълнява командата Tools > Update Schematics. Системата дава съобщение за броя на обновените елементи.
Обновената схема с новите символи е показана на фиг. 1.10
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фиг. 1.10 Обновената схема с новите символи.

4. Свързване на елементите с проводници

За да се свържат елементите, се използва командата Place > Wire (горещи клавиши P, W). Курсорът на мишката добива вид на кръстче. 
Ще бъде обяснено как се свързва резисторът R3 с базата на транзистора T2 Доближава се курсорът до долния извод на R3, при което сивият кръст се превръща в червена звезда. Щраква се с левия бутон на мишката или се натиска клавишът Enter, с което се задава начало на линията. Премества се курсорът надолу и се доближава до базата на транзистора Т2. От резистора тръгва плътна линия, показваща прекарвания проводник. След нея продължава прекъсната линия, подсказваща къде ще бъде следващия сегмент на проводника. Трябва да се отбележи, че системата предлага няколко режима на чертане (ортогонални линии, 45 градуса, произволен ъгъл), които могат лесно да се превключват чрез клавишите SHIFT+интервал. Режимите притежават подрежими, които се превключват чрез клавиша интервал. Чрез щракване с мишката се задават възловите точки, в които проводникът сменя посоката си. Доближава се курсорът до базата на транзистора Т2, при което сивият кръст се превръща в червена звезда, а линията става Г-образна. Щраква се с левия бутон на мишката, за да се фиксира положението на начертания сегмент. Чрез клавиша Esc се завършва чертането на сегмента.
По подобен начин се извършва и чертането на следващите вериги. При необходимост елементите се преместват чрез влачене. В местата на допиране на две връзки автоматично се добавя точка на съединение. При необходимост от ръчно поставяне на точка на съединение се използва командата Place>Manual Junction.
Ако се налата преместване на вече свързан елемент, обикновеното преместване чрез влачене с левия бутон на мишката не е много полезно, тъй като се премества само елементът, а връзките остават на място. За динамично преместване, при което елементът остава свързан, по време на влаченето трябва да се задържи клавишът CTRL.
5. Захранващи портове
За добавяне на захранващи портове се използва командата Place>Power Port. Преди да се постави захранващият порт на чертежа, може да се зададат свойствата му в диалогов прзорец, показващ се при натискане на клавиша Tab. Задават се цвета, стила (кръгче, стрелка, земя, хоризонтална отсечка и др), ориентацията и името на етикета. Като име на етикета се задава GND ​​- за земя, 5V – за извод, към който се подава напрежение или подходящо буквено означение, ако е сигнален вход или изход (фиг. 1.11).
6. Вериги и етикети на вериги.
Всички начертани на схемата линии между електрически обекти в процеса на компилация на проекта ще бъдат разпознати като вериги, след което ще им бъдат присвоени уникални имена. За да може в бъдеще да се идентифицират лесно най-важните вериги, може принудително да им се присвоят имена с помошта на специални електрически обекти – етикети на вериги.

В настоящата схема най-важни са веригата на захранването, земята и веригата на изходния сигнал, поради което ще им бъдат присвоени съответни названия. За да се именува веригата се използва командата Place>Net Label, при което към курсора се прилепва малък правоъгълник. Натиска се клавиша Tab, при което се отваря диалогов прзорец, в който се задава името на веригата, например 5V или GND, и се потвърждава с ОК. След това се разполага етикета над съответната верига и се щраква с левия бутон на мишката. 
На фиг. 1.11 е показана схемата в завършен вид.
.
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фиг. 1.11 Окончателен вид на схемата
2. Компилация на проекта (проверка на грешките).
Основна част от компилацията е верификацията на проекта, представляваща откриване на груби грешки, като неприсъединени изводи, късо съединение, загубени вериги, символи или даже листи. За сложни многолистови проекти с множество цифрови елементи, където вероятността от грешки расте в геометрична прогресия, автоматичната проверка е незаменима.
2.1. Настройка на параметрите на проекта

Настройките се извършват в прозореца Option for Project, който се отваря чрез командата Project >Project Options.

Параметрите за проверка на правилата на електрическите съединения се задават в първите две преградки на прозореца: Error Reporting и Connection Matrix.
В първата преградка Error Reporting са изброени повечето възможни грешки, свързани с построяването на проекта и чертането на схемата. За всяко нарушение може да се присвои степен на критичност: фатална грешка, грешка, предупреждение. Степента No Report позволява да не се докладва. За текущия проект ще се използват настройките по подразбиране, които може да се възстановят чрез бутона Set To Default.
Във втората преградка Connection Matrix се задават правила за проверка на електрическите съединения (ERC). Всички правила са представени във вид на матрица, по вертикалните и хоризонтални оси на която са приведени различни типове електрически обекти (изводи, портове, входове на листи). Разноцветните квадрати, разположени в пресечните точки на редовете и стълбовете, показват степента на критичност на съединението на съответните обекти. Зеленият цвят показва, че съединението се допуска и няма грешка, жълтият – предупреждение, оранжевият – обикновена грешка, червеният – фатална грешка. Промяната на степента на критичност се извършва с последователно щракане върху нужния квадрат. 
Настоящата схема съдържа резистори и кондензатори, които имат само пасивни изводи (Passive Pin), а също транзистори, с изводи от типа Input Pin. Матрицата ще бъде настроена така, че да показва ненатоварените пасивни изводи. За целта се открива пресечното квадратче на реда Passive Pin и стълба Unconnected. Променя се цвета на квадратчето на жълт, което съответства на предупреждение.
2.2. Настройка на компаратора

Компараторът представлява модул, който проследява внесените в проекта изменения и сигнализира за тях. Настройката на компаратора се изпълнява в преградката Comparator на диалоговия прозорец Option for Project. Тъй като този проект е прост и липсва йерархия, настройките се оставят по подразбиране.
2.3. Компилация на проекта

В процеса на компилация се изпълнява проверка на всички настройки, направени в диалоговия прозорец Option for Project. Компилацията се стартира чрез командата Project > Compile PCB Project. Компилираният проект се показва в панела Compiled, а възможните грешки – в панела Messages (съобщения), който се включва чрез едноименния бутон в долната част на екрана. Ако схемата е нарисувана коректно, този панел остава празен. 
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